install libelf-dev

To try to avoid this message during build:
warning: Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel
<https://gitlab.com/freifunk-region/stuttgart/site/-/jobs/200400306>
5 jobs for master in 1 minute and 16 seconds (queued for 1 second)
latest
Status Job ID Name Coverage
  Build
passed #13
build

00:01:16

failed #12
build

00:01:02

failed #11
build

00:02:58

failed #10
build

00:00:57

failed #9
build

00:00:14